SCIENCEAND (OMMON STREAM

ACCORDING TO THE LATEST
PAPER PATTERN OF BOARD

4
Bl
-
-
Q.
> 2
O
W

B NUZHAT MEMON



[ o | o

SCIENCE AND COMMON STREAM

Creating HTML forms using KompoZer

Cascading Style Sheets and JavaScript

Designing simple website using KompoZer

Introduction to E-Commerce

Introduction to M-Commerce

Object-Oriented concepts

Java Basics

Classes and Objects in Java

Working with Array and String

Exception handling in Java

File handling

Publishing documents using LaTeX

Other useful free tools and services

Compiled by Nuzhat Memon




I
PAPER PATTERN
STD 12

SCIENCE AND COMMON STREAM
(ENGLISH MEDIUM)

GSHEB SYLLABUS FOR THE ACADEMIC YEAR
2025-26

FORMAT OF THE QUESTION PAPER

Theory Question Paper | 100 marks | 2 hours
Practical Question Paper | 50 marks | 2 hours

PURPOSE BASED WEIGHTAGE

Purpose Knowledge | Understanding | Activity | Skill | Total Marks
Weight in Marks 30 30 30 10 100
Weight in Percentage 30% 30% 30% | 10% 100%
WEIGHTAGE OF MARKS ACCORDING TO THE DIFFICULTY LEVEL
Difficult level Easy | Medium | Hard | Total
Difficult level ( Percentage) | 50% | 35% | 15% [100%
WEIGHTAGE OF MARKS OF THE SYLLABUS
Weightage
Chapter No Chapter Name Theory | Practical
1 Creating HTML forms using KompoZer 10 07
2 Cascading Style Sheet and JavaScript 12 08
3 Designing simple website using KompoZer 10 10
4 Introduction to E-Commerce 10
5 Introduction to M-Commerce 12
6 Object Oriented Concepts 10 -
7 Java Basics 10 10
8 Classes and Objects in Java 10
9 Working with Array and String 10
13 Other useful free tools and services 06
Total 100
Timing | 2 hrs

Compiled by Nuzhat Memon




CHAPTER 1

CREATING HTML FORM USING KOMPOZER

Introduction to Form
= With the increase in the use of Internet many activities have become online.
= Web page is used to fill information about ourselves or a product.
= HTML forms are used to help the visitors of the website to input data.
» [t (Form) allows for more interactivity and control in data entry.
= Example: when a user wants to open a mail account or register on a website, user
needs to enter their personal details in a form.
o In order to obtain such information on Internet, HTML forms are used.
o This data is further stored by the application and also used to retrieve the
details about the users registered on the website.
» Aformin HTML is a container used to collect different kinds of inputs from the user.
» HTML forms contains the form elements like label, checkbox, text input field,
radio button, submit button, reset button and many more.
* Form elements are used to enter the data as well as validate the data within the
forms.
* Form used to enter the data can be created using HTML tags.

Four elements are used in a HTML form:
1) Form
2) Input
3) Textarea
4) Select and Option

Form Elements
» The form element is used to create a HTML form.
» Form element acts as a container for all the elements used in the form.
» The tag <form>....</form> is used to implement the form element.
SYNTAX: <form action="filel.html” method="post”>

</form>
= The form element uses two attributes namely action and method

Action Attribute

* The action attribute is used to specify where to send the form data when the
form is submitted.

» The action attribute takes a filename as value.

= This file given as action attribute (filel.html) is opened when the user clicks on the
submit button after filling the data in the form.

Method Attribute
* The method attribute specifies the HTTP method to be used when sending the
data.
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* The method attribute can take two values: GET and POST
®* The default value for method attribute is GET.
GET Method POST Method

The GET method retrieves the data from | In the POST method, the data is sent as
the form and sends it to the server by | a block through the HTTP transaction.
attaching it at the end of the URL. POST method attribute send the data in
the body of the request.
The GET method allows only a limited | POST method does not have any
amount of information to be sent at a time. | restriction on data length.

Input Elements
» The input elements are used to insert various fields in the form.
» Fieldslikes 1) Textbox 2) Password 3) Radio button
4) Checkbox 5) Submit button 6) Reset button
* The tag <input>...</input> or <input> is used to implement input element.
* The input tag has three different attributes like type, name and value.
o The type attribute of the input element specifies the field that is to be created in
the form.
o The name attribute specifies the name to be used for the field in the form.
o The value attribute specifies the default value of the field in the form.

Various Input Elements created using type attribute of <input> tag:

Type Description Syntax

Text or » A user can enter any text or data of his | <input type="text”
Textbox choice in the text field. name="var”

txt = Textbox is used to enter data like | value="txt">

username, emailld, mobileno etc
» Textbox is created by giving text value to
type attribute of input tag.

Password » Password field is used to enter password | <input
----- | = Password field is similar to text field. type="password”
* In password field the characters are not | name="var”>
displayed to the user.

» Instead the character typed is converted
into non readable format.

Radio button |= Any one radio button can be selected at | <input

® a time from a group of radio buttons. type="radio”

* Generally radio button used to select a | name="var”
single item from a given group of items. | value="txt">

Checkbox = Multiple check boxes can be selected at | <input
a time. type="checkbox”
» Generally used to select a multiple items | name="var”
from a given group of items value="txt">
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Submit button | = On clicking the submit button, the values | <input

label of data entered in the form is submitted to | type="submit”
the file specified in the action attribute of | value="label”>
the form element.
Reset button |= On clicking the reset button, the values of | <input

label data entered in the form are cleared and | type="reset”
set back to default values. value="label”>

Textarea Element
* The Textarea element allows multi-line text input
* The tag <textarea>....</textarea> is used to implement textarea element.
» Textarea allows entering unlimited number of characters.
» Textarea can be used to enter comment, report or a long description of product.

SYNTAX: <textarea name="address” rows="5" cols="20">
some content goes here
</textarea>

* The size of a textarea element can be specifies using rows and cols attributes.

* The rows attribute is used to set the number of rows of text that will be visible
without scrolling up and down.

* The cols attribute is used to set the number of columns of text that will be visible
without scrolling right or left.

Select and option Element (Drop down menu)
» The select element is used to create a drop down list or menu in a form.
* The tag <select>....</select> is used to create a drop down menu.
* The option element is used to specify the values to be displayed in the menu.
* The tag <option>...</option> is used to create the elements within the menu.
= Selected attribute is optional. Specific option from the dropdown menu can appear as
selected by default by using selected attribute.
SYNTAX: <select>
<option>Bhuj</option>
<option selected>Ahmedabad</option>
<option>Baroda</option>
</select>
Practical Exercise @ 0 O o n

C File | C/Users/memon/Documents/f1.html

Application Form
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Use of IDE to create a form

* Creating a form using HTML tags is a tedious process.

» A simpler method to create a form is to use an IDE.

= Full form of IDE is Integrated Development Environment

= An IDE is a software application that provides complete facilities to programmer to
develop software.

» [DE provides GUI (Graphical User Interface), Text/code Editor, a compiler and/or
interpreter and a debugger.

» Kompozer, Eclipse, JBuilder and Netbeans are all examples of some open source
IDEs.(Remember, Netchain or Nutscells are not an example of open source IDEs)

Introduction to KompoZer

= KompoZer is a free open source web development IDE.

» KompoZer can be downloaded from http://www.KompoZer.net.

* [t provides a webpage editor which has a simple graphical interface known as
WYSIWYG (“What You See is What You Get”)

» KompoZer is a complete web authoring system which integrates webpage
development and web file management.

* The users can also edit the webpages by using the source code and making changes.

» KompoZer incorporates a Site Manager which gives rapid access to the files on both
local machines and remote servers.

» Web pages and associated files can be uploaded to a remote server from within
KompoZer.

» Jtalso supports the use of “Styles” through CSS (Cascading Style Sheet)

Interface of KompoZer
* To Open KompoZer: Applications>Programming=>KompoZer OR
Double click KompoZer icon on desktop

= To view the different toolbars and status bar, click on View->Show/Hide
_ Different Options in the

Menu bar ——
seohies | e L 1822-48 @ | Show/Hide option of
Fom Tokw? ] | I : View menu:
Ry — e - ———| Composite Toolbar,
— 3 Format Toolbar1,
Format Toolbar2,
Phes e Edit Mode Toolbar,
Status bar,
Site Manager and
Rulers.
KompoZer has eight
B i menus: File, Edit,
i View, Insert, Format,
o fdme ™ | Table, Tools, Help.
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3 Toolbars below Menu bar:
Composite Toolbar, Format Toolbarl and Format Toolbar2

Composite toolbar * To create new file, open a file, save a file or publish a
web page.

Format Toolbar1l and * To format the text, add bullets/numbering and

Format Toolbar2 perform similar formatting operations.

Note: Select Heading1 from Format Toolbarl. Here six
types of Headings available from Heading 1 to Heading 6.
In Format Toolbar2, Four types of alignments are
available i.e. left, center, right and justified.

2 Panes in the center of the Kompozer Window:
Site Manager and Blank Web Page

Site
Manager

» In the center of the window at the left side.

= Site Manager is a powerful tool used to navigate within the site or
between the sites.

= We can close the site manager pane by clicking on close button or
press F9.

Page Pane
(Blank
webpage)

* The page pane shows a blank untitled webpage.
Edit Mode toolbar
The bottom right side of the window shows Edit mode toolbar with
3 viewing modes: Normal, HTML tags and Preview
All the three viewing modes provide editing facilities.
* The Normal View mode:
o Normal view is very similar to preview mode.
o Innormal mode, webpage along with the table outlines are visible.
= HTML Tags View:
o The HTML Tags view helps those who are familiar with HTML.
o A Yellow marker is used to indicate the start tag for all elements.
o Clicking on a marker selects and highlights whole of the element.
= Preview Mode:
o The Preview mode offers the page view as seen in a browser.
o In the Preview mode the script do not run and therefore their
effects will not be seen.
o The links also does not operate in preview mode
The Left side of the page pane shows 3 tabs:
Design tab, split tab and source tab
o The Design tab is used to design the web page.
o The Split tab display the HTML source of the current element.
o Source tab shows all details of the HTML code and helps in
editing the source code.
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Status Bar
= Status bar is on the bottom of the window.
= When we click on any item in page, its structure appears in the status bar.

Customize any toolbar
= Right click on the respective toolbar and click on “Customize Toolbar” option.

Creating New File
» Open KompoZer, Click File>New
» A dialog box with title “Create a new document or template” will be shown.
» Select “Blank document” option
= At the bottom of the dialog box, select “New tab” option in “Create in” dropdown
menu. This allows to create the page in a new page.
% Click on the Create button

< Create a new document or template EJ

Withat kind of file do you warnt to creats?

(&) 4 blank document

[icreats a XHTML document [ Strict DTD

) & new document based on a termplate

O & blank template

> T

=)
| —

Opening an Existing File

» File>Open OR Click on Open icon = present on the Composite Toolbar.
= [f the file has been opened recently, then you can also open the file from
File>Recent pages.

Creating a form using KompoZer

Insert2>Form—>Define Form
OR

Click on Form icon from the
Composite Toolbar

Form Properties dialog box
opens up when we click
Insert>Form—>Define Form

-
— Form Button
Form

r o
Form Properties =)
Settings
Form Name: [ ]
Action URL: [ |
Encoding: \ E[
Target Frame: ‘ E[

= Form name, Action URL and method
settings are viewed when user defines form in
Form Properties dialog box.
[Note: Field value option is not in Form
Properties dialog box of KompoZer]

= In the action URL, enter the filename where
you want the form data to be submitted.

= Select the method POST from the method
drop down menu.

» Untitled is a default name of the new form
created in KompoZer.

* [n normal view, the form is inserted with
light blue color outline in the untitled page.

*In normal view, the forms are shown
surrounded by a dotted blue box.
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Inserting elements in the form

Insert 2 Form—->Define label

Place the cursor in the form and type text
in the label.

LABEL First Name To come out of the label field, click
anywhere outside the field.
Insert>Form~-> Form Field Text Field used for First Name, Middle
Form Field Properties N > Name, Last Name, Email and Mobile.
r Field Type Form Field Properties dialog box with
= E]J Field Type, Field Name and Initial Value
(= Field Name: to give a Field Name
s — Field Type: Select Text from Field Type
TEXT dropdown menu.
FIELD I == Initial Value: To show some text before
e the user actually enters data.
A Click on More Properties, it shows
| AcceptTypes: advanced properties related to the field
like field size, maximum length.
Required Field Size & Maximum Length
can be given in Fewer Properties section
Insert>Form~>Form Field Radio button is used to select single item
T > from group of items
- Field Bype Radio button is used for gender field.
Briicion M [ Field Type: Radio Button
Field Settings - - Group Name must be the same for all
RADIO Group Nime . . .
BUTTON e pf)SSlble answers in radio button. .
O Infialy Selected Field Value: To give value to the radio
S o Propedies button example: Female
To keep the option of the radio button
= — selected, when the form is loaded then
check the box “Initially selected”
Insert>Form—>Form Field Checkbox is used to select multiple items
“‘F?:r;x Fleld Propcr‘;-s ? from group Of items.
(v Checkbox is used for hobby field.
ﬂ ‘ Field Type: Check Box
. Pk St = Keep the Field Name same for all the
CHECKBOX Field Name options of checkbox.

Field Vaboe

[ Initially Checked

v More Properties

Adianced [da.

DK Cancel

Field Value: To make checkbox of type
Hobby. Example: Singing

To keep the option checked when the form
loads select “Initially Checked” or
“Initially Selected”
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TEXT
AREA

Insert=> Form—> Text area

Text Area Properties »

=

~ Settings -

Field Name: |

Rows: |

Columns: ‘

l 4  Fewer Properties

]

Wrap Mode: [ Default

[] Disa
Tab Index ‘
Access Key: | 7‘
Initial Text:

[C] Read Only

]

bled

Advanced Edit...

[ ox

] [ cance ]

To insert address or comment or long
description

Multi line textarea and allow unlimited
text

Textarea Properties dialog box opens
when click on Insert->Form—-> Textarea
with Field: Field Name, Rows, Columns
and Initial Text

Two main attributes: rows and cols

In Text Area Properties dialog box, the
Initial Text Field is used to enter a
suitable text which will be displayed
when the form loads.

SELECTION
LIST

Insert-> Form—> Selection List

Selection Lin2 Properties

x|

Text

- Selection List
List Name |
Hogre

[ Dizabled
b Inder

Selected €3

Add Option
Add Group

[ Mukigle Selection

a  Mowe Up
Move

Aduanced [de.

OK Cancel

Selection List is to be selected for city
field.

Selection List Properties dialog box is
appears when Insert>Form—> Selection
List is selected

Add option button is clicked in Selection
List Properties dialog box to enter values
one after another.

Select the option “Initially Selected”
when adding option as default one. This
checkbox gives an initial value.

SUBMIT
BUTTON

Insert->Form

Button Properties

—>Form Field
——

~ Settings

Type Submit

Name: |submit

[

Value: |Submit

| [ v More Properties ]

Advanced Edit...

OK

) (G ]

| [

 c——

RESET
BUTTON

Insert->Form

Select Submit Button from Field Type
dropdown menu

Type Submit in both the Field Name and
Field Value text boxes.

—>Form Field

Field Type: Reset Button
Enter text in Field Name and Field Value
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The form at present is in the normal view.
To have a preview of the form, click on Edit mode toolbar and select Preview.
You can also see the source code of the form by clicking on the Source tab.

Saving a File

To save the file,
o File—>Save
OR

o Click on Save button %+ on the Composition Toolbar.
The Page Title dialog box opens while saving a file in KompoZer to give a suitable title
to the webpage.
The page Title will be displayed in the browser windows title bar when viewed in the
browser.
Website name will be assigned as page title when more than one web page is created.
A new dialog box “Save Page As” is opened that prompts the user to enter a filename
and specify the location where you want to save the file.
Save the file with html or htm as an extension.
Note: If you are creating a website and this is the home page that will open when you
type the website’s URL, then save th page with the name index.html.

Changing background color to the form

e feagroung Cotst X

Predetomned (ulom

EE [ EETE
||| CCOEE
EEN NEFEEE
ENENEEEEEN
ENEEEEEEEE
EEEEEEEEEE
Bachgprand image: -
- I e ——
e ) e s 3 e ORI
Advancod [$2 Satunstior: 0 §‘am ) ::1 Name  ahde
Boghtmex 133 % Bee 13 é{ O Tiseparent

To give a background color to the form from white color to any other color, go to
Format = Page Colors and Background

This will open a Page Colors and Background dialog box.

Select “Use custom colors” option.

Click the background option and this display “Block Background Color” dialog box.
Select the color and click on OK button.

Full form
IDE Integrated Development Environment
GUI Graphical User Interface
WYSIWYG What You See Is What You Get
CSS Cascading Style Sheet
HTML Hypertext Markup Language
HTTP Hypertext Transfer Protocol
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Kompozer’'s Menu-Options

Starting KompoZer Program

Application 2 Programming—>KompoZer

To view different toolbars & status bar

View—>Show/Hide

Define a new Form

Insert=>Form—> Define Form

To insert the label

Insert->Form—=> Define Label

To insert an input text field

Insert>Form—=>Form Field> Text

To create a password field

Insert>Form—=>Form Field—=> Password

To create a radio button

Insert=>Form—=>Form Field=> Radio button

To create a checkbox

Insert>Form—=>Form Field—=> Check Box

To create a textarea

Insert>Form—> Textarea

To create a pull down menu

Insert->Form—>Selection List

Inserting Submit button

Insert>Form—=>Form Field—=> Submit Button

Inserting Reset button

Insert>Form—>Form Field=> Reset Button

To give a background color

Format->Page Colors and Background

Creating a new file

File > New
OR
New icon on Composite Toolbar

Open an existing file

File 2 Open
OR
Open icon on Composite Toolbar

Saving a File

File = Save
OR
Save icon on Composite Toolbar

To open a recent used file

File=>Recent Pages

Element and its tag

Form element

<form>....</form>

Input element

<input>...</input>
OR
<input>

Textarea element

<textarea>....</textarea>

To create a dropdown menu or list

<select>....</select>

To create the elements within the menu

<option>....</option>

Tag and its attributes
Form tag 2 attributes: Method and Action
Note: 2 Values of Method attribute: Get and Post
Input tag 3 attributes: type, name and value
Textarea Tag 2 attributes: rows, cols
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TEXTUAL EXERCISE
1. Which of the following is a container used to collect different kinds of inputs from the
user?
(A) Form (B) Webpage (C) Text (D) Input
2. Which of the following element is used to create an HTML form?
(A) Textarea (B) Form
(C) Select and option (D) Input
3. Which of the following is the tag used to implement form element?
(A) <form>....</form> (B) <form>....<form>
(C) </form>...</form> (D) <frm>....</frm>

4. Which of the following attribute of form is used to specify where to send the form data
when the form is submitted?
(A) method (B) action (C) submit (D) input
5. Which of the following attribute of form specifies the HTTP method to be used when
sending the data?

(A) submit (B) action (C) method (D) input
6. Which of the following values are used by method attribute?

(A) GET and POST (B) GET and SET

(C) GET and PUT (D) SET and POST

7. Which of the following method allows only a limited amount of information to be sent
at a time?

(A) GET (B) POST (C) SET (D) PUT
8. Which of the following method sends the data as a block through the HTTP transaction?
(A) GET (B) SET (C) PUT (D) POST

9. Which of the following attribute of the input element specifies the field that is to be
created in the form?

(A) Input (B) Type (C) Name (D) Value
10. Which of the following element allows multi-line text input?
(A) Textarea (B) Input
(C) Select and option (D) Form
11. Which of the following element is used to create a drop down list or menu in a form?
(A) Input (B) Textarea (C) Select (D) Form
12. Which of the following is a free open source web development IDE ?
(A) HTML (B) Kompozer (C) Scite (D) Base
13. Which of the following stands for “WYSIWYG” ?
(A) When You See Is When You Get (B) What You See Is When You Get
(C) What You See Is What You Get (D) When You See Is What You Get
ANSWER KEY

1. A 2.B 3. A4 B5 C6.A7. A8 DO B 10. A
11. € 12. B 13. C
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