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CHAPTER 1

INTRODUCTION TO MULTIMEDIA

Communication

» Communication is an integral part of our life.

= We use various means of communication like radio, newspaper, television,
theater, movies, internet and others.

= All these medium help us gain knowledge or educate us.

= A Single medium of information is not enough to convey meaningful messages to
a variety of audience.

* The more the mediums of information you use the impact of the
communication increases.

Multimedia

» Multimedia is all about adding various effects to make communication effective.

* The term multimedia has been coined from two terms: multiple and media

* Multimedia means usage of multiple media to communicate.

= |n other words, multimedia is a collection of different media elements like text,
audio, graphics, video and animation.

* The combination of all media elements makes the communication more Structural
and understandable to the user

Elements of Multimedia
= 5 Elements of Multimedia are:
v' Text
v' Audio
v Graphic
v Video
v' Animation
= Computer plays a vital role in the development of these media elements.
= A Computer capable of handling text, graphics, audio, video and animation is called
as multimedia computer.

Text Element in Multimedia

* Including text in multimedia is the basic step towards development of
multimedia presentation.

» Proper use of text and words in multimedia presentation will help to
communicate the idea and message to the user.

= Text can be of any type, a word, a single line or a paragraph.

* The textual data for multimedia can be developed using any text editor.

» However to give special effects we need graphics software.

= Word processing software to create textual data:

v OpenOffice Writer v' Ms-Word
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* Terminology of Text Element:
v’ Typefaces
v" Fonts
v’ Size
v’ Style

Typeface
= A typeface is family of character or letters which have similar look.
» For example: times, Arial, courier and others.

Font
» Typeface have different style and size known as Font.
Bold 12 point
Italic 20 point
underline  and so on.
and others.
Example:

Arial typeface with 20 point and bold

Courier typeface with 18 point and underline

Size
= Size is the distance between the top of the letter to the bottom point.
» Jtis expressed in points.

Categories of Typeface
» Typeface categorized into : Serif and Sans-Serif
Serif fonts
o Serifis a little decoration at the end of the character.
o Example: Times, Century, Bookman
o Serif fonts are easy to read on a printed page as they guide the eye along the
line of text.
o So they are used when there is lot of text to be read.

San-serif font

o Sans in French means ‘without’ and it means without decoration.

o Example: Arial, Verdana and Helvetica

o They are usually for headlines and titles.

o But on computer screen due to low resolution, serif fonts are difficult to read
than the sans serif
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Traditional method vs. Multimedia

» Text used in traditional pen and paper method is different form text in
multimedia.

* In Traditional method, we convey the information using only text.

* In multimedia we have other elements along with text. And these elements
together to convey meaningful information. And that information is in the form of
text, sound, pictures etc.

* Thus text in multimedia should be short, to the point and attractive to get the
attention of the user.

Practice Exercise: Text Element
» Open OpenOffice Impress.
* Open a blank presentation in OpenOffice Impress.
= Select Fontwork Gallery icon on drawing toolbar.
o If Drawing toolbar is not visible, then go to View->Toolbars->Drawing
* In the Fontwork Gallery dialog box, select any style and click OK.
» Double Click on the object to enter into the text edit mode.
= Replace the default “Fontwork” text with text “Gujarat tourism”.
» Press esc key to exit the text edit mode.

Audio

» Sound is the most important element of multimedia.

* We can define sound as a meaningful speech in any language.

* The term sound is used in the analog form, and the digitized form of the

sound is called audio

When we are presenting in front of the audience, text and images without any sound

are helpful.

* In the absence of the presenter, sound plays an important role. The best example is
educational CD.

» Thus when a user sees the presentation, he/she is able to understand it easily by
seeing the animation along with the voice.

= Now a days, computers support multimedia application. They come alongwith
required hardware & software needed for MM applications.

» Hardware - inbuilt sound card, speaker, mics & web camera

= Software - The Operating System (OS) provides application that can be directly
used for capturing audio and video.

Audio Recording Application:
Applications->Sound and video->Sound recorder
o Choose File>New
o Use the Record as drop-down list to select 1 of the following recording option:
CD quality, Lossless CD quality, Lossy Voice
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» To start recording Control - Record or Record Button
» To stop recording Control - Stop or Stop Button

= To Play back the recording Control - Play or Play button

* To run the audio mixer File 2 Open Volume Control

» To save the recording File = Save As

Audio Formats

= Sounds are stored in media file.

» File extension is used to find the type of media file

= .wav is the most popular uncompressed sound format on the internet and it is
supported by all popular browsers.

* The .mp3 is the new compressed format for recorded music. So if you want to use
the recorded music, .mp3 is the best choice.

File : .
Extension Type of File Description
.mid, .midi MIDI File MIDI (Musical Instrument Digital
Interface) files contain music data.
.Im, .ram Real Audio File ram (Real Audio Metadata) is
combination of audio and video.
.wav Wave File Waveform audio file.
.wma Windows Media Audio File | Audio file compressed with
windows media compression.
.mp3, .mpga | Mp3 Audio File Compressed audio format.
Image

» Generally multimedia presentations are graphics/image based.
* Information communicated through images is easier to remember and understand.
* [mages used in a multimedia application can be
o photographs converted into digital form with the help of scanners or
o generated on the computer.
= Computers store the pictures mainly of two forms:
o Bitmap or raster graphics (2D Matrix)
o Vector graphics (Mathematical Equation)
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Two Types of Image Files

Bitmap/Raster Images

» Computer store the pictures in the form of pixels maps is known as bitmap or

raster images.
o Pixel is the small dot on the screen.
Pixel stands for picture element (pix=»Picture and el=» Element).
A map is a two dimensional (2D) matrix of these dots.
Each pixel in this map contains values representing a color.
When an image is sent to be displayed on the screen, the picture data is
converted to pixels.
* Thus a bitmap is simple matrix of tiny dots which forms an image on the
computer screen.

0 O O O

Vector Images
= Computer store the images in the form of mathematical equations.
= Both bitmap and vector graphics looks the same on the screen.
o But when you enlarge the bitmap image, it will get blur and the pixel will
get enlarged
o The vector image on the other hand looks the same when enlarged because
the data is stored in the mathematical form and the values are recalculated
when displayed on the screen

Image Formats
» Bitmap image file formats like gif, jpeg and png use compression within the file
itself.
» In Open office writer, select Insert->Picture to insert a picture.
» The picture used can be :
o A file already present in the computer
o We can scan the picture using scanner and convert it into digital format to be used
further by the computer.
o We can make changes to our images by using programs like Adobe Photoshop,
GIMP, MS-Paint and others

File Extension Type of File Description

.bmp Bitmap Image Uncompressed Image file used to
store bitmap digital images.

gif Graphical Common for web graphics with small
Interchange images and images with text.
Format File Uses limited number of colors
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.png Portable Used to store graphics for web images
Network and supports upto 32 bit colors.
Graphic It was an improvement over gif.

Jjpeg / .jpg Joint Common image format used by
Photographic digital cameras.

Expert Group Supports upto 24 bit colors.

.psd Photoshop Image file created by Adobe
Document Photoshop

Video & Animation

* Animation can add great power to any multimedia application.

» Any static presentation becomes lively by adding a video or animation

» The term video refers to the sequence of natural scenes captured using analog or
digital video capturing device. This device can be a web camera, digital camera or
even mobile phone.

* Animation is a visual change over time. The digital images are played one after the
other to create a moving effect.

» Animation is created from drawn pictures and video is created using real time
visuals.

= Some example of animation movies are Kung fu Panda, Smurfs and the Angry Bird.

Classification of Animations
2D Animation
v" In 2D (two-dimensional) animation, the visual change occurs on the x and y
axis of the screen.
v' This type of animation is simple.
v Some example of 2D animation software are Macromedia flash, Synfig Studio
and Pencil.

3D Animation

v" In 3D (three-dimensional) animation, the visual change occurs along three axis
namely X, y and z.

v' This type of animation gives almost a realistic view of the image as can be
seen by the human eye.

v Some examples of 3D animation software are Maya, Blender and 3D Max.

Video Recording Application
To record a video using VLC Media Player and Cheese Webcam Booth
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VLC Media Player

Download it from Ubuntu Software Center

Itis a free open source multimedia player.
eese Webcam Booth

Open source video recording software

Available on Ubuntu Software Center.

Working with VLC Media Player

Open VLC media player.

Select Media—> Open Capturing Device that will open “Open Media” Dialog.
Select Video device name and Audio device name.

Select “convert” from the play drop down menu. That will open “Convert” dialog
box. In that dialog box, select the destination and filename.

Check “Display the output” checkbox to see what you are recording.
Click on the Start button.

Once recording done then click on the stop button to stop the recording

Video

Formats

= Mp4 is most widely used format for the internet video.
» |t is supported by Flash players, YouTube as well as HTML5.

File Extension Type of File Description
.avi Audio Video Developed by Microsoft to play videos in
Interleave File windows environment.
.wmv Windows Media .wmv (Windows Media Video) is a
Format File compressed video format developed by
Microsoft for internet streaming
applications.
.mpg, .mpeg Moving Pictures | Popular video format used for creating
Expert Group File | movies distributed over internet.
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.mov Quick Time Developed by Apple. Files are
Format File compressed and are easier to download
from internet.

Im, .ram Real Video Format | .ram (Real Audio Metadata) are
File combination of audio and video.
swi, flv Adobe Flash Animated file containing text and images.

Shockwave File Created by using Adobe Flash software.

.mp4 MPEG4 Video File | Commonly used for sharing video file on
the internet.

Interactive objects
* Project where users are given navigational control and variety of media
» Navigation Control:
o Attimes the user may want to skip a portion of the presentation or want to again
go through the same portion.
o The user is given buttons or hyperlinks for navigation. When these interactive
objects are clicked, the flow of the presentation changes as per the user’s choice.
= Variety of Media
o Earlier the internet browser supported only one media element: Text. Text was
also limited to single font and color.
o Now a day latest internet browser support all the media elements.
o Some media elements can be handled inline and some require plug-in
* Inline media objects are specified inside the program using a specific
<inlinemediaobject> tag.
* Plugin are extra helper programs that can be easily installed and used as a
part of the web browser.

Classification of Multimedia
» Generally multimedia is classified into two namely: Interactive and non-
interactive multimedia.
= |n interactive multimedia,
o The sequence and timing of media elements can be controlled by the user.
o For example: a multimedia CD-ROM titles and games- The user can control the
media elements & use the multimedia according to his/her needs & preference:
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Mass Media Multimedia

® The communication is one way in * Multimedia does not remain passive
traditional mass media like but can control the elements.
television, radio or newspaper. In e Two way communication.

other word, we can say that the
process originate from the source
and is delivered to the mass
audience.

e One way communication

¢ Deliver of content to audience

¢ Deliver of content to user.

* In non-interactive multimedia,
o The user simply watches the media as it plays from beginning to the end. He/she
has no control over the flow.
o For example: a corporate presentation or a multimedia.

Classification of multimedia based on its applications
= Another classification of multimedia is based on its applications:
Entertainment or Edutainment.
o All types of games, movies are examples of entertainment multimedia wherein
the purpose is to entertain the user.
o The multimedia titles that educate the user are classified under edutainment
multimedia. Example: All types of educational CD’s

Usage of Multimedia
» Multimedia has become integral part of our life.
» Multimedia find its application in various areas.
= Some of the usage of multimedia in various fields:
o Education and Training
o Advertisement
o Journalism
o Entertainment

Education and Training

= We have been using presentations consist of charts, tables and other objects to
impart knowledge since a long time.

» Multimedia is used to produce computer based training courses commonly known
as CBT.
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= CBT lets the user go through a series of presentations, animations, text about a
particular topic along with the examples.
» CBT are used for almost all the age groups right from kindergarden to post
graduates.
» Edutainment is an informal term used to describe combining education with
entertainment, especially multimedia entertainment
» Uses of multimedia in education and training are:
v Recording or broadcasting lecture
v" Using video conferencing we can hear an expert speaker from a distant location.
v Demonstrating surgeries or other techniques that learners may not otherwise
have the opportunity to see and later put them in practice.
v Record student’s performance to enable feedback.

Advertisements
= |t is the major source of launching and promoting a product by the manufacturing
companies in the market.
o Excited animation, effects and slogan can make an advertisement popular.
o For Example, Jujus and pup dog in Vodafone Advertisement.

Entertainment

» Multimedia is heavily used in the entertainment industry to develop special effects
in animations and movies.

= Movies like Ice age, Jurassic park, Avatar will always be remembered for their
special effects and animations.

» Multimedia games are available either as CD-ROM'’s or online.

= With usage of virtual gaming, two players in different countries can play a game
sitting on their computers.

Journalism

* There are many magazines and newspaper that are published periodically,

» E-newspaper and E-magazines are also available online where we can see the videos
related to particular news.

Stages in Multimedia Production

Step 1: Research and Analysis

» Find out about the audience, their skill, needs & qualification.

» Gather as much information as possible about the content to be presented

Step 2 : Scripting and Flowcharting
= Scripting or flowcharting means deciding the flow of the multimedia project.
= A flowchart to show the main menu and the branching when a user selects a

particular option.

Compiled by Nuzhat Memon



CHAPTER 1

* Draw a flow chart starting with main menu and then the subpages that are linked
with each others.

Step 3: Storyboarding

» The actual visualization of the project takes place.

» The designer decides how each screen should look like, which media elements are to
be used and where to place them on the screen.

Step 4: Collection and Construction
» The designer is ready with the prototype and starts creating the graphics and other
media elements to be used in the project.

Step 5: Programming

= After the collection and construction of media elements, they are combined
together into a final product using software packages like Macromedia Flash, Synfig,
Hypercard

Step 6: Testing
= We check if all the media elements are working as per the requirement or not.
= Also whether the audience targeted will find the design and content attractive or

not.
SOLVING TEXTUAL MCQS
1. The term multimedia has been coined from which of the following terms:
(A) Mix, media (B) Mid, mediate
(C) Multi, mediator (D) Multiple, media
2. How many maximum media elements are combined in Multimedia?
(A) Three (B) Four (C) Five (D) Eight
3. Which of the following terms defines a meaningful speech in any language?
(A) Video (B) Sound (C) Text (D) Animation
4. Times, Century, Bookman are some examples of which of the following font?
(A) Arial (B) Typeface (C) Serif (D) Sans serif
5. Which of the following is an audio file compressed with Windows Media compression?
(A) .mid (B) .wav (C) .mp3 (D) .wma

6. Which of the following terms represent the distance between the top of the letter to the
bottom point?

(A) Size (B) Style (C) Length (D) Width
7. Which of the following terms represent typefaces that have different styles and sizes?
(A) Font (B) Text (C) Letter (D) Character

8. Macromedia Flash, Synfig studio and Pencil are examples of which of the following

animation types?
(A) 3D (B) 2D (C) 4D (D)5D
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9. Which of the following terms represent a small dot on the computer screen?

(A) Pixel (B) Point (C) Cursor (D) Cell
10.Which of the following terms represent a classification of images?
(A) Vector, raster (B) Bitmap, raster
(C) Picture, clipart (D) Graphics, picture
11.Which of the following terms represent a visual change over time?
(A) Text (B) Audio (C) Animation (D) Graphics
12.Which of the following terms represent a two dimensional matrix of dots?
(A) Screen (B) Map (C) Cell (D) Array

13.Which of the following terms is full form of MIDI?
(A) Musical Instrument Data Interface  (B) Musical Instrument Digital Interface

(C) Musical Image Digital Interface (D) Musical Instrument Digital Image
14.Which of the following terms represent the most common image format used by digital
cameras?
(A) .gif (B) .jpeg (C) .tif (D) .bmp
15.Which of the following is sued to store the images are stored in form of mathematical
equation?
(A) Vector (B) Raster (C) Bitmap (D) Picture
16.Which of the following devices help us to convert photographs into a digital format?
(A) Scanners (B) Modem (C) Printer (D) Monitor

17.Which of the following terms represent PNG?
(A) Programmable Network Graphics (B) Photo Network Graphic
(C) Portable New Graph (D) Portable Network Graphic
18.Which of the following terms represent a helper programs that can easily installed and
used as a part of the web browser?
(A) Plug-in (B) Text (C) Video (D) Audio
19.In which of the following terms can Multimedia be classified?
(A) Intelligent and non-intelligent
(B) Interactive and non-interactive multimedia
(C) Intuitive and non-intuitive
(D) Informative and non-informative
20.In which of the following animation types does the visual change occur in the Xand Y
axis?
(A) 2D (B) 3D (C) 4D (D)5D

ANSWERKEY

. b 2.C 3. B 4 C 5 D 6.A 7.A 8 B 9. A 10. A
11. C 12. B 13. B 14. B 15. A 16. A 17. D 18. A 19. B 20. A
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